Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: 7.7 нужна ВК dialmail с поддержкой SSL

v7: 7.7 нужна ВК dialmail с поддержкой SSL
Я
   komaroff
 
20.07.21 - 15:10
Здравствуйте, поиск выдал старую версию и нерабочие ссылки. Прошу помочь в поиске.
Вообще задача к существующей отправке через сервера без SSL добавить отправку через mail.ru.
Сейчас с учетом паролей для сторонних приложений в настройках безопасности вообще можно использовать dialmail c mail.ru?
Или "использоватьSSL=1" и с обычным паролем для входа через веб-интерфейс работает?
   Смотрящий
 
1 - 20.07.21 - 15:28
(0) Таки открой для себя CDO
   Garykom
 
2 - 20.07.21 - 15:34
(0) сколько платишь?
   Volodja
 
3 - 20.07.21 - 15:43
Функция ОтправитьПисьмоЧерезCDO(СтруктураCDO) 

    Письмо = СоздатьОбъект("CDO.Message");
    _СтруктураОтвета=СоздатьОбъект("Структура");
    _СтруктураОтвета.Вставить("ОК");
    _СтруктураОтвета.Вставить("Объект");
    _СтруктураОтвета.Вставить("ОписаниеОшибки");
    _СтруктураОтвета.Вставить("",0);
    _СтруктураОтвета.Вставить("Письмо",Письмо);
    _СтруктураОтвета.Вставить("");
    
    
    //Р = Новый Структура("ОК, Объект, Описание", 0, Письмо, "");
    Письмо.to = СтруктураCDO.Кому;
    Письмо.from = СтруктураCDO.Отправитель;
    Письмо.cc = СтруктураCDO.Копия;
    Письмо.bcc = СтруктураCDO.СкрытаяКопия;
    _сзВложения=СтруктураCDO.Вложения;
    Для иии=1 по _сзВложения.РазмерСписка() Цикл
        Письмо.AddAttachment(_сзВложения.ПолучитьЗначение(иии));
    КонецЦикла;
    Письмо.Subject = СтруктураCDO.Тема;
    Письмо.TextBody = СтруктураCDO.Текст;
    Письмо.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/sendusing").Value = 2;
    Письмо.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpserver").Value = СтруктураCDO.СерверSMTP;
    Письмо.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpauthenticate").Value = СтруктураCDO.Аутентификация;
    Письмо.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/sendusername").Value = СтруктураCDO.ПользовательSMTP;
    Письмо.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/sendpassword").Value = СтруктураCDO.ПарольSMTP;
    Письмо.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpserverport").Value = СтруктураCDO.ПортSMTP;
    Письмо.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpusessl").Value = СтруктураCDO.SSL;
    Письмо.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpconnectiontimeout").Value = СтруктураCDO.ТаймАут;
    Письмо.Configuration.Fields.Update();
    Попытка
        глЗанестиЗаписьВЖурналЛогированния("ПочтовыйКлиент",,,"Отправка письма email:"+Письмо.to);
        Письмо.Send();
    Исключение
        _СтруктураОтвета.ОписаниеОшибки = ОписаниеОшибки();
        глЗанестиЗаписьВЖурналЛогированния("ПочтовыйКлиент",,,"Ошибка при отправке письма на email:"+Письмо.to+" Текст ошибки: "+ОписаниеОшибки());
        Возврат _СтруктураОтвета;
    КонецПопытки;
    _СтруктураОтвета.ОК = 1;
    Возврат _СтруктураОтвета;
КонецФункции
   Volodja
 
4 - 20.07.21 - 15:52
Функция ОтправитьПисьмоЧерезDialMail(СтруктураПисьма) 
    _СтруктураОтвета=СоздатьОбъект("Структура");
    _СтруктураОтвета.Вставить("ОК");
    _СтруктураОтвета.Вставить("Объект");
    _СтруктураОтвета.Вставить("ОписаниеОшибки");
    _СтруктураОтвета.Вставить("",0);
    _СтруктураОтвета.Вставить("Письмо",);
    _СтруктураОтвета.Вставить("");
    
    
    
//    ЗагрузитьВнешнююКомпоненту(КаталогИБ()+"DialMail.dll");

    ОтправкаПочты= СоздатьОбъект("AddIn.SMTP");
//    SystComm = СоздатьОбъект("AddIn.SystComm");

//    ОтправкаПочты.УстановитьКодировкуИСпособКодирования(22,3);

    ВыбФайл="";
    _сзВложения=СтруктураПисьма.Вложения;
    Для иии=1 по _сзВложения.РазмерСписка() Цикл
        ВыбФайл=ВыбФайл+_сзВложения.ПолучитьЗначение(иии)+?(иии=_сзВложения.РазмерСписка(),"",",");
    КонецЦикла;
    
    ОтправкаПочты.РабочийКаталог=КаталогПользователя();
    ОтправкаПочты.ИспользоватьПрокси=0;
    ОтправкаПочты.ИспользоватьSSL=СтруктураПисьма.SSL;
    ОтправкаПочты.ВестиЛогФайл = 1;
    ОтправкаПочты.ИмяЛогФайла = ПолучитьКаталогLOGS()+"\"+"dialmail.smtp.log";
    АдресКому=СтруктураПисьма.Кому;
    АдресКопии=СтруктураПисьма.Копия;
    Логин = СтруктураПисьма.Отправитель;
    Пароль = СтруктураПисьма.ПарольSMTP;
    ОтправкаПочты.ПочтоваяПрограмма="Client on DialMail";
    ОтправкаПочты.MakeContentDescriptionTag = 0;
    ОтправкаПочты.ТипТелаПисьма=0;  
    ЗаголовокСообщения = СтруктураПисьма.Тема;
    текст  = СтруктураПисьма.Текст;
    текписьмо=ОтправкаПочты.СоздатьПисьмо(Логин,АдресКому,АдресКопии,ЗаголовокСообщения,,текст,ВыбФайл);
    
    Если ОтправкаПочты.Подключиться(СтруктураПисьма.СерверSMTP,СтруктураПисьма.ПортSMTP,Логин,Пароль,1)=0 тогда
        Сообщить("Не смогли подключиться к SMTP-серверу");
        _СтруктураОтвета.ОК = 0;
        ОтправкаПочты.Отключиться();
    КонецЕсли;
    _СтруктураОтвета.ОК=ОтправкаПочты.ОтправитьПисьмо(,1,0);
    Возврат _СтруктураОтвета;
КонецФункции
   komaroff
 
5 - 20.07.21 - 18:23
Невнимательность..

Попытка использовать атрибут "ОтправкаПочты.ИспользоватьSLL=1;" давало ошибку "поле агрегатного.. " :)))
Я подумал что используемая ВК "DialMail 2.7.6b swa" устарела и не имеет этого атрибута.
Исправил имя атрибута. Всё отправляется через smtp.mail.ru Можно использовать основной пароль, можно пароль для внешнего приложения. И так, и так работает.

Volodja, огромное спасибо за листинги, но лучше подскажите как можно обновить DialMail, видел посты где обсуждались более новые версии, например DialMail 2.7.6.13 DialMail_2.7.7.1.dll не могу получить письмо больше 5 мегабайт

Смотрящий, CDO у меня даёт ошибку "CDO.MESSAGE.1 Транспорт не удалось подключиться к серверу" пока разбираюсь.

Garykom, спасибо за предложение, если что - обращусь к вам.
   Garykom
 
6 - 20.07.21 - 18:25
Самое простое для 77 это юзать .net 
Или ВК написать или через "Ъ"
   Злопчинский
 
7 - 20.07.21 - 20:34
готовое по CDO https://infostart.ru/public/14131/
если проблемы с ssl - читать там же в комментах
   big
 
8 - 20.07.21 - 20:56
Знающие CDO и иже с ним - а как получить почту средствами ОС?  На пуркуа эта CDO, если получать письма все равно надо чем-то другим?
(7) Да в топку все "тунели", известный костыль.
   Злопчинский
 
9 - 20.07.21 - 21:05
(8) "а как получить почту средствами ОС?"
- задавался этими вопросами. вроде как никак.
   uno-group
 
10 - 21.07.21 - 10:47
(8) А нафига из 1с почтового клиента делать. Получай любым клиентом сортируй сохраняй для загрузки в 1с то, что нужно,
Из 1с проверяй нужную папку и загружай. когда нужно работать с Вордовским или Екселевским файлам ты же не реализуешь работу с этими файлами на прямую (хотя ничего этому не мешает), а юзаеш костыли оле и т.п. Чем Почта отличается Ексель?
   Volodja
 
11 - 21.07.21 - 12:09
(5) есть 2.7.6.16 куда скинуть?
   Злопчинский
 
12 - 21.07.21 - 12:12
(10) у меня девки сабж из (7) очень аквтивно использовали. всякие счета, отчеты итп в качестве оперативной отсылалки, очень удобно. сисадмина попросил, он еще задание сделал на подчистку истории отправленных писем с глубиной в 2 недели...
   big
 
13 - 21.07.21 - 12:26
(10) Не "нафига", а очень удобно. Потому что с почтой работает оператор, обрабатывающий заявки, приходящие в электронном виде от разных поставщиков. И на какой фих вручную тянуть эти файлы по каким-то "загрузочным" папкам и т.д. и т.п. С рабочего места, не глядя ни в один пресловутый почтовый клиент, оператор получает файлы заявок, обрабатывает их и тут же отсылает ответы, при чем в нужном формате, даже не видя ни файлы, ни даже не зная где они хранятся после всех этих операций и как они вообще выглядят.

И при чем тут ексель и почта? Всё гораздо шире. У нас в почте помимо екселя есть тексты, xml, pdf и всякие хитровыдраные файлы от хитровыдраных сетей.
   Злопчинский
 
14 - 21.07.21 - 12:30
(13) не возражаем!
   uno-group
 
15 - 21.07.21 - 13:02
(12) Про отправку я не спорю. У самого все через СДО работает. И автоматическая загрузка происходит. 1с ка сканирует определенную папку и грузит все необходимое. А как в эту папку попадут данные это уже забота админов. Код 1 раз написан и 20 лет уже работает. Почтовых клиентов уже нацать раз приходилось перенастраивать. То гугл, что то поменяет, то яндекс забанят, то шифрование решат прикрутить. То заявки на ФТП, вайберы, телеграммы программы электронного документооборота и т.п.  начинают присылать. Идеологически это не правильно, наша задача написать загрузку-выгрузку, а обеспечить поступление данных работа админов.
   komaroff
 
16 - 21.07.21 - 13:34
(11) Volodja, на почту bikomaroff@gmail.com пожалуйста
   Злопчинский
 
17 - 21.07.21 - 13:35
(15) угу. у меня проще, я даже загрузку автоматическую не делал, бо присылают как бог на душу положит.
есть обработка-ЦУП, которая тянет простой файл заявки вида "артикул-количество", а файлики девочки сами уже подсовывают.
   uno-group
 
18 - 21.07.21 - 15:33
(17) Я делал для не формализированных данных по принцыпу. Прочитать 50 строк загрузка в ТЗ на экране далее девочка тыкает в нужную ячейку и жмет кнопку что это типа в 5 колонке артикул или в 6 штрих-код в 13 количество и делее уже экспортирует.
Или загрузка подготовленных файлов когда удаляют из него весь мусор и 1 колонка артикул 2 кво. и потом скармливают эго в экспорт.
   Злопчинский
 
19 - 21.07.21 - 15:39
(18) ну, такого говна у меня тоже есть ;-) даже с крависыми бантиками. переснь реквизитов для согласования. визуальное отображение прочтианного файла, на нем визуально отображение привязанных строк=столбцов, разные такие схемы для разных клиентов. короче - тошниловка сплошная ;-)
   big
 
20 - 21.07.21 - 19:28
(15)(17)(18)(19) Со стороны так и не понятно - у кого же длиннее? ))
   Смотрящий
 
21 - 21.07.21 - 20:51
Мой толще
   tgu82
 
22 - 22.07.21 - 08:46
У меня все работают с CDO, хотя
и через TheBat тоже, правило составил,
по приходу письма с нужного ящика кидает приколотый файл в папку, а в 1С обработчик ожидания создает сам заявки от покупателей
   Volodja
 
23 - 22.07.21 - 08:52
(16)
  bikomaroff@gmail.com
    SMTP error from remote mail server after end of data:
    host gmail-smtp-in.l.google.com [74.125.131.26]:
    552-5.7.0 This message was blocked because its content presents a potential
    552-5.7.0 security issue. Please visit
    552-5.7.0 https://support.google.com/mail/?p=BlockedMessage to review our
    552 5.7.0 message content and attachment content guidelines. c19si18581988lfv.443 - gsmtp
   Volodja
 
24 - 22.07.21 - 08:55
(16)
возьми с облака
https://cloud.mail.ru/public/nqC9/6iB4gmtNL
пароль на архив - 1
   komaroff
 
25 - 22.07.21 - 21:23
(24)  Volodja, благодарю покорно, забрал.
   komaroff
 
26 - 22.07.21 - 21:36
А у кого-нибудь работает DialMail с SSL под win10x64 или server win2012x64? У друга на 2012, а у меня дома под win10x64 -  не работает. regsvr32 не грузит ssleay32 и libeay32 (через syswow64 пробовал). Соответсвенно в логах dialmail:

23.07.21 00:59:02.942 Не подключились к SSL
23.07.21 00:59:02.948 SMTP ErrorCode = 10091
23.07.21 00:59:02.953 SMTP ErrorDesc = Network subsystem is unusable

А под server win2003х32 прекрасно всё работает.. получается под новые х64 системы только .NET либо CDO?


Список тем форума
 
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.