Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

1С и яндекс почта

1С и яндекс почта
Я
   sanek23_89
 
26.09.20 - 15:40
Здравствуйте. Нужна помощь. Отправляю письмо из 1с
Профиль = Новый ИнтернетПочтовыйПрофиль;
    Профиль.АдресСервераSMTP = "smtp.yandex.ru";
    Профиль.ПортSMTP = 465;
    Профиль.Пользователь = "логин";
    Профиль.Пароль = "пароль";
    Профиль.ПользовательSMTP = "логин";
    Профиль.ПарольSMTP = "пароль";
    Профиль.АутентификацияSMTP = СпособSMTPАутентификации.Login;
    Профиль.ТолькоЗащищеннаяАутентификацияSMTP = Ложь;
    Профиль.ИспользоватьSSLSMTP = Истина;
    Профиль.POP3ПередSMTP = Ложь;
    Почта = Новый ИнтернетПочта;
    Письмо = Новый ИнтернетПочтовоеСообщение;
    
    Текст = Письмо.Тексты.Добавить("мой текст письма");
    Текст.ТипТекста = ТипТекстаПочтовогоСообщения.ПростойТекст;
    Письмо.Тема = "ТемаПисьма";
    Письмо.Отправитель = "логин";
    Письмо.ИмяОтправителя = "ИмяОтправителя";
        
    Письмо.Получатели.Очистить();
    Письмо.Получатели.Добавить(ПарамEmail);
    Почта.Подключиться(Профиль);
    Почта.Послать(Письмо);
    Почта.Отключиться();

Письмо уходит. Но в отправленных письмах ящика с которого отправляли не вижу этого письма
   PR
 
1 - 26.09.20 - 15:41
Да
   sanek23_89
 
2 - 26.09.20 - 15:42
Как сделать, чтобы письмо было в отправленных письмах?
   ДенисЧ
 
3 - 26.09.20 - 15:45
(2) Через попу (поп3) - никак.
Через имап - можно. Ближе к вечеру покажу код, часов в 18 подними ветку
   ДенисЧ
 
4 - 26.09.20 - 17:10
(2)
У меня работает где-то так. (код кривой и грязный, но работает)
                                Если УчетнаяЗапись.ОтправлятьВОтправленные Тогда
                                    ящики = ИнтернетПочтаIMAP.ПолучитьПочтовыеЯщики();
                                    фл = Ложь;
                                    Для Каждого ящ из Ящики Цикл
                                        Если ВРег(ящ) = "ОТПРАВЛЕННЫЕ" ИЛИ ВРег(ящ) = "SENT" Тогда
                                            Попытка
                                                ИнтернетПочтаIMAP.ТекущийПочтовыйЯщик = ящ;
                                            Исключение
                                                ТекстОшибок = Символы.ПС + ТекстОшибок + (Строка(УчетнаяЗапись) + ". Ошибка помещения письма в 'Отправленные'
                                                |" + ОписаниеОшибки());
                                                
                                                #Если Клиент Тогда
                                                Если ПоказыватьОкноВыполнения Тогда
                                                    СтрокаТаблицыСостояния.Состояние = Перечисления.СостоянияСобытий.Отменено;
                                                КонецЕсли;
                                                #КонецЕсли
                                            
                                                Продолжить;
                                                
                                            КонецПопытки;
                                            фл = Истина;
                                            Прервать;
                                        КонецЕсли;
                                    КонецЦикла;
                                    Если фл Тогда
                                        рез = ИнтернетПочтаIMAP.Послать(ПочтовоеСообщение,, ПротоколИнтернетПочты.IMAP);
                                        сс = Новый Соответствие;
                                        фл = Новый ФлагиИнтернетПочтовогоСообщения;
                                        фл.Прочитанное = Истина;
                                        
                                        ПараметрыОтбораIMAP = Новый Структура;
                                        ПараметрыОтбораIMAP.Вставить("Новые", Истина);

                                        новыеСообщения = ИнтернетПочтаIMAP.ПолучитьИдентификаторы(, ПараметрыОтбораIMAP);
                                        
                                        Для Каждого элем Из новыеСообщения Цикл
                                            сс.Вставить(элем, фл);
                                        КонецЦикла;
                                        ИнтернетПочтаIMAP.УстановитьФлагиСообщений(сс);
                                    КонецЕсли;
                                КонецЕсли;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.