Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как изменить пароль Пользователя в режиме Предприятие

Как изменить пароль Пользователя в режиме Предприятие
Я
   fazliddinuz
 
05.09.20 - 09:31
Добрый день, есть само письная конфигурация.  Нужно сделать так, чтобы обичные пользователи могуть изменят свойи пароли. Много раз питался стедать это, но без административных прав видается ошибка что нет доступа. Если включить админитсративные правы тогда можно и в конфигуратор входить. Подскажите пожалуйста как сделать ?
Заранее спасибо
   Фрэнки
 
1 - 05.09.20 - 10:06
Эта самописная конфигурация в каком-то интерфейсе управляемых форм? На каком-то БСП основана? Или это морально устаревшие "обычные формы" и тем более без БСП?
   Ненавижу 1С
 
2 - 05.09.20 - 10:24
Можно при записи пароля установить привелигированный режим программно и потом отключить. Точнее он сам отключится
   fazliddinuz
 
3 - 05.09.20 - 10:40
(1) Это конфигурация в управляемых формах но без БСП.
   fazliddinuz
 
4 - 05.09.20 - 11:16
(2) Спасибо! В дали мне идея и дальше по этой теме https://forum.infostart.ru/forum9/topic76974/ решил проблема половина.

Создал Общий привелигированный модуль и там экспортная процедура. В начале процедуры установил привелигированный режим.
И если пользователь изменяет  свой пароль эта получается но при изменение пароль другого пользователя или при попытка нового пользователя все равно ошибка видается что нет прав для выполнение операции.

В чем может быть проблема?

Вот мой код 

В модуле форме:

Функция ИзменитьПользователь(Наим, Рол, Парол)



 ПаролниУзгартириш.ФойдаланувчиниТахрирлаш(Поль,Наим,Парол, Рол);     

    
КонецФункции


В общем привелигированном модуле ПаролниУзгартириш :

Процедура  ФойдаланувчиниТахрирлаш(Фойд, Номи, Парол, Рол)  Экспорт
    УстановитьПривилегированныйРежим(истина);
    
        Если НЕ Фойд.Имя="" Тогда
        Фойд.Имя  = Номи;
        Фойд.ПолноеИмя = Номи;
        Фойд.Пароль = Парол;
        Фойд.Роли.Очистить();
        Фойд.Роли.Добавить(Метаданные.Роли.Найти(Рол));
        Фойд.АутентификацияСтандартная=Истина;
        Фойд.Записать();
    
    Иначе
        НовФойд = ПользователиИнформационнойБазы.СоздатьПользователя();    
        НовФойд.Имя = Номи;
        НовФойд.Роли.Добавить(Метаданные.Роли.Найти(Рол));
        НовФойд.Пароль= Парол;
        НовФойд.ПоказыватьВСпискеВыбора=Ложь;
        НовФойд.АутентификацияСтандартная=Истина;
        НовФойд.Записать();
    КонецЕсли;

КонецПроцедуры
   fazliddinuz
 
5 - 05.09.20 - 16:01
up
   acht
 
6 - 05.09.20 - 16:10
(4) > ПаролниУзгартириш.ФойдаланувчиниТахрирлаш(Поль,Наим,Парол, Рол);

Как, однако, 1С на киргизском сурово звучит.
   fazliddinuz
 
7 - 26.09.20 - 14:04
(6) Это не на киргизском а на Узбекском язык
   ДенисЧ
 
8 - 26.09.20 - 14:09
Неадминистратор может менять только свой пароль.
   Cthulhu
 
9 - 27.09.20 - 02:40
(8)+: но можно загнать изменения паролей в регистр сведений - и слепить фоновое задание, которое под админом будет по таймауту парсить этот рс, менять тошоненадо на тошонадо и при успехе - зачищать записи... нэ?..

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.